בעיה מעצבנת בQT...

asi123456789

New member
בעיה מעצבנת בQT...

טוב, קודם כל אני חייב להגיד שאני די חדש בלינוקס, אז בבקשה תפרטו את התשובה כמה שיותר.
אז זאת הבעיה, כל פעם שאני מפעיל תוכנה שמשתמשת בQT ומריץ את הקובץ CONFIGURE, זה נותן לי את השגיאה הבאה: Qt (>= Qt 3.0.3) (library qt-mt) not found. Please check your installation! For more details about this problem, look at the end of config.log. Make sure that you have compiled Qt with thread support! אני לא יודע למה זה רושם לי 3.0.3 עשיתי RPM -q qt וזה מצא לי QT 3.1.1, מישהו דיבר איתי בקשר שצריך לעשות איזה לינק לאנשהו והלינק אינו נכון אבל לא ממש הבנתי. מישהו אולי נתקל בבעיה או יודע איך לפתור אותה? בתודה מראש.
 

ezaton

New member
אתה מנסה להדר תוכנה בלי חבילות

פיתוח. אם תריץ rpm -qa | grep -i qt תוכל לראות שחסרות לך חבילות qt-dev או qt-mc או דברים כאלו. כאשר אתה מנסה להדר, לא מספיק שיש לך את הספריות, אתה צריך את קבצי הפיתוח, אותם קבצים שיאפשרו לך לבנות בעזרתם תוכנה. שים לב שהסימון הוא גדול שווה, ולא שווה, כך שהתוכנה דורשת QT בגירסה 3.0.3 בתור מינימום. היא מציינת שחסר לך qt-mt. השתמש במנהל החבילות החביב עליך והתקן את החבילות החסרות. בהצלחה.
 

asi123456789

New member
איך אני עושה את זה?

אם אני רוצה להתקין את החבילות דרך RPM, איך אני יכול לעשות את זה? אני צריך את הדיסק ההתקנה ואם כן איזה דיסק זה? (יש לי 3). איך אני יכול לראות בדיוק איזה חבילות חסרות לי? מצטער על השאלות המטופשות, אמרתי כבר שאני משתמש ממש חדש בזה.
 
למעלה