אפליקצית הרכבת: שאלת תם..

מצב
הנושא נעול.
אפליקצית הרכבת: שאלת תם..

אפליקצית הרכבת: שאלת תם..
מדוע דובר הרכבת לא שולח הודעות בדחיפה למשתמשים באירועים שבהם צפוי עיכוב משמעותי?
למשל... אם פתאום אדם נדרס בקו החוף וצפויים שיבושים.. למה הם לא משתמשים באפליקציה כדי להודיע לציבור? הרי אם יש לי את האפליקציה כנראה אני לא סתם נוסע מזדמן.. ואפשר גם לעשות בתוך האפליקציה הגדרה לאם רוצים לקבל הודעות דחיפה או לא.
 

davidfainshtein

New member
מנהל
רעיון מצויין.

אפליקצית הרכבת: שאלת תם..
מדוע דובר הרכבת לא שולח הודעות בדחיפה למשתמשים באירועים שבהם צפוי עיכוב משמעותי?
למשל... אם פתאום אדם נדרס בקו החוף וצפויים שיבושים.. למה הם לא משתמשים באפליקציה כדי להודיע לציבור? הרי אם יש לי את האפליקציה כנראה אני לא סתם נוסע מזדמן.. ואפשר גם לעשות בתוך האפליקציה הגדרה לאם רוצים לקבל הודעות דחיפה או לא.
רעיון מצויין.
אעביר את זה לדובר.
 

davidfainshtein

New member
מנהל
להלן התשובה שקיבלתי:

מקווה שזה ימומש..
אין דבר יותר מעצבן מלהגיע לתחנה ולגלות שהרכבת מושבתת מכל סיבה שהיא..
להלן התשובה שקיבלתי:
הצעתך כבר נמצאת בתכנון ויישום.
כך שכיוונת לדעת גדולים.
 
אז הנה משהו שהם לא חשבו עליו

להלן התשובה שקיבלתי:
הצעתך כבר נמצאת בתכנון ויישום.
כך שכיוונת לדעת גדולים.
אז הנה משהו שהם לא חשבו עליו
שהודעות הדחיפה יהיו לפי קווים...
אם אני נוסע בקו חיפה - ת"א אז שאני לא אקבל הודעות על שיבושים בקו ירושליים בית שמש.
שיאפשרו למשתמש להגדיר את הקווים הרלוונטים אליו ואז כל הודעה שרלוונטית לקו תגיע אליו.
כיוון שאין הרבה קווים ברכבת ולא צפוי שיהיה סדר גודל של יותר מ 30 קווי רכבת שונים ב10 שנים הבאות זה בהחלט בר ביצוע..
&nbsp
&nbsp
 

nOnAmE134

New member
אהבתי, אחלה שיטה

אפליקצית הרכבת: שאלת תם..
מדוע דובר הרכבת לא שולח הודעות בדחיפה למשתמשים באירועים שבהם צפוי עיכוב משמעותי?
למשל... אם פתאום אדם נדרס בקו החוף וצפויים שיבושים.. למה הם לא משתמשים באפליקציה כדי להודיע לציבור? הרי אם יש לי את האפליקציה כנראה אני לא סתם נוסע מזדמן.. ואפשר גם לעשות בתוך האפליקציה הגדרה לאם רוצים לקבל הודעות דחיפה או לא.
אהבתי, אחלה שיטה
אגב, מה יש באפליקציה שלא כל הטלפונים החכמים יכולים להריץ אותה? לי למשל יש Galaxy Ace Plus, ואין תמיכה בזה.
למישהו יש מושג מדוע?
 
אפליקציה נכתבת עבור מערכת הפעלה מסוימת.

אהבתי, אחלה שיטה
אגב, מה יש באפליקציה שלא כל הטלפונים החכמים יכולים להריץ אותה? לי למשל יש Galaxy Ace Plus, ואין תמיכה בזה.
למישהו יש מושג מדוע?
אפליקציה נכתבת עבור מערכת הפעלה מסוימת.
לכל תוכנה באשר היא (חוץ מתוכנה שנכתבת בשפת JAVA) יש חלק בתוכנה ש"מדבר" על מערכת ההפעלה... וזה החלק שצריך להחליף כאשר רוצים שאפליקציה תרוץ על מערכת הפעלה אחרת.
&nbsp
בסלולר זה קצת יותר בעייתי, כי יש מערכות הפעלה שמכירות רק שפה מיועדת ואז כדי שאפליקציה תרוץ על מכשיר אחר צריך לכתוב אותה בשפה אחרת לגמרי.
 
מה שכתבת לא לגמרי נכון, כי כל עוד מדובר באותה מערכת הפעלה

אפליקציה נכתבת עבור מערכת הפעלה מסוימת.
לכל תוכנה באשר היא (חוץ מתוכנה שנכתבת בשפת JAVA) יש חלק בתוכנה ש"מדבר" על מערכת ההפעלה... וזה החלק שצריך להחליף כאשר רוצים שאפליקציה תרוץ על מערכת הפעלה אחרת.
&nbsp
בסלולר זה קצת יותר בעייתי, כי יש מערכות הפעלה שמכירות רק שפה מיועדת ואז כדי שאפליקציה תרוץ על מכשיר אחר צריך לכתוב אותה בשפה אחרת לגמרי.
מה שכתבת לא לגמרי נכון, כי כל עוד מדובר באותה מערכת הפעלה
(במקרה של Galaxy Ace Plus מדובר באנדרואיד) אין צורך לכתוב את האפליקציה מחדש עבור כל מכשיר. מה שכן, יכול להיות שהאפליקציה כבר הפסיקה לתמוך בגירסת האנדרואיד הישנה שעל המכשיר.
&nbsp
ובלי קשר, רוב האפליקציות לאנדרואיד כתובות ב-Java, וזה לא אומר שאין בהן חלק ש"מדבר" עם מערכת ההפעלה. לדבר עם מערכת ההפעלה לא אומר רק להתקמפל לקוד מכונה, אלא גם לדבר עם API-ים של מערכת ההפעלה, ואת זה מן הסתם גם Java יודעת לעשות כמו כל שפה אחרת.
&nbsp
 
איזו גירסת אנדאוריד יש לך?

אהבתי, אחלה שיטה
אגב, מה יש באפליקציה שלא כל הטלפונים החכמים יכולים להריץ אותה? לי למשל יש Galaxy Ace Plus, ואין תמיכה בזה.
למישהו יש מושג מדוע?
איזו גירסת אנדאוריד יש לך?
לעתים לא טורחים לתמוך בגירסאות אנדרואיד ישנות, כי זה מצריך עוד עבודה ועוד בדיקות, וממילא כמות המשתמשים בגירסאות ישנות הולכת וקטנה. לדוגמה, אפליקציות שנכתבות היום כמעט בוודאות לא יתמכו בגירסאות אנדרואיד מתחת ל-4.0.
 

nOnAmE134

New member
2.6 – משהו כזה. אז זה חסר סיכוי, אלא רק להיכנס דרך האתר


איזו גירסת אנדאוריד יש לך?
לעתים לא טורחים לתמוך בגירסאות אנדרואיד ישנות, כי זה מצריך עוד עבודה ועוד בדיקות, וממילא כמות המשתמשים בגירסאות ישנות הולכת וקטנה. לדוגמה, אפליקציות שנכתבות היום כמעט בוודאות לא יתמכו בגירסאות אנדרואיד מתחת ל-4.0.
2.6 – משהו כזה. אז זה חסר סיכוי, אלא רק להיכנס דרך האתר
 

Ofekalef1

New member
אתה תמיד יכול להיעזר באפליקציות האחרות שמכילות נתונים על ר"י

2.6 – משהו כזה. אז זה חסר סיכוי, אלא רק להיכנס דרך האתר
אתה תמיד יכול להיעזר באפליקציות האחרות שמכילות נתונים על ר"י
 
מצב
הנושא נעול.
למעלה