לגלישה באתר בגירסה המותאמת לסלולאר
| הוספת הודעה
הגדרות תצוגה

הגדרות עץ הודעות

מאפייני צפייה

הצג טקסט בתצוגה
הצג תגובות באופן
עדכן
1230312,303 עוקבים אודות עסקים

פורום לינוקס

לינוקס?לינוקס הופכת בשנים האחרונות אלטרנטיבה מאוד חזקה גם לשרתי היוניקס המסורתיים, וגם לשרתים מבוססי חלונות, משום שהיא רצה מעל חומרה זולה יחסית (מחשבי PC), ומשום היציבות שלה, שמתחרה בשרתי יוניקס "כבדים" מסחריים ויקרים.לינוקס היא מערכת הפעלה, על כל האמור בכך, שפיתוחה החל בשנות התשעים המוקדמות על ידי אדם בשם לינוס טורוואלדס, וצמחה, בד בבד עם התפתחות האינטרנט שבלעדיו היא לא היתה צומחת (ויש אומרים, מתקיימת) דרך תרומה של מתנדבים, וכאלו שרצו להתאים את המערכת לצרכיהם, בתהליך אבולוציה - שבו הטוב והמתאים נשאר, והפחות טוב נושר - לכדי מערכת חזקה מאוד, מחד, וגמישה מאוד, מאידך. לכן, כמובן, קוד המקור של המערכת עצמה, ורובן המכריע של התוכנות עבורה, פתוח לכל דורש.שנים אחדות לאחר הופעתה בשוק השרתים, הן האירגוניים, והן שרתי האינטרנט, הנתונים להתקפות בלתי פוסקות ודורשים מערכות מאובטחות במיוחד, פרצה המערכת גם לתודעת הקהל הביתי. לאחר עיכוב מה, שנגרם כתוצאה מתמיכה רחוקה משלמות בשפה העברית, הגיעה המערכת גם לארץ.כיום לינוקס תומכת בעברית באופן (כמעט) מלא, ומסוגלת לשמש אלטרנטיבה, כתחנת קצה (או שולחן עבודה) כמעט לכל מערכת מבוססת חלונות או מק שקיימת בשוק. יתרונה הגדול, מעבר לאלו שצויינו כבר, הוא במחירה האפסי (על פי רשיון המערכת, ניתן לשכפל אותה באופן חוקי ולגיטימי), ובמגוון התוכנות הגדול הקיים עבורה - בו ניתן למצוא אלטרנטיבה לכמעט כל תוכנת חלונות בשוק.בפורום הזה אנחנו מנסים לעזור למשתמשים חדשים להכנס לעולם הלינוקס, השונה מהותית מעולם החלונות, ולקדם דיונים מקצועיים ברמות שונות, מתוך מטרה לקדם את תפוצת המערכת הנהדרת הזאת (כך לדעתנו) בארץ - הן בשוק הביתי, והן בשוק השרתים האירגוניים.אנו נשמח לעזור בכל שאלה או בעיה.אנא הקפד/י לשמור על כללי השיחה באינטרנט - שפה הולמת, המנעות מפרסומות, המנעות מהפצות, כדי לאפשר לפורום להשאר ברמה הגבוהה בה הוא נמצא עכשיו. כמו כן, מותר שרשור יחיד לכותב בעמוד הראשי, מטעמי נימוס כלפי כותבים אחרים.אולי זה הזמן לעבור ללינוקס?

הנהלת הפורום:

אודות הפורום לינוקס

לינוקס?לינוקס הופכת בשנים האחרונות אלטרנטיבה מאוד חזקה גם לשרתי היוניקס המסורתיים, וגם לשרתים מבוססי חלונות, משום שהיא רצה מעל חומרה זולה יחסית (מחשבי PC), ומשום היציבות שלה, שמתחרה בשרתי יוניקס "כבדים" מסחריים ויקרים.לינוקס היא מערכת הפעלה, על כל האמור בכך, שפיתוחה החל בשנות התשעים המוקדמות על ידי אדם בשם לינוס טורוואלדס, וצמחה, בד בבד עם התפתחות האינטרנט שבלעדיו היא לא היתה צומחת (ויש אומרים, מתקיימת) דרך תרומה של מתנדבים, וכאלו שרצו להתאים את המערכת לצרכיהם, בתהליך אבולוציה - שבו הטוב והמתאים נשאר, והפחות טוב נושר - לכדי מערכת חזקה מאוד, מחד, וגמישה מאוד, מאידך. לכן, כמובן, קוד המקור של המערכת עצמה, ורובן המכריע של התוכנות עבורה, פתוח לכל דורש.שנים אחדות לאחר הופעתה בשוק השרתים, הן האירגוניים, והן שרתי האינטרנט, הנתונים להתקפות בלתי פוסקות ודורשים מערכות מאובטחות במיוחד, פרצה המערכת גם לתודעת הקהל הביתי. לאחר עיכוב מה, שנגרם כתוצאה מתמיכה רחוקה משלמות בשפה העברית, הגיעה המערכת גם לארץ.כיום לינוקס תומכת בעברית באופן (כמעט) מלא, ומסוגלת לשמש אלטרנטיבה, כתחנת קצה (או שולחן עבודה) כמעט לכל מערכת מבוססת חלונות או מק שקיימת בשוק. יתרונה הגדול, מעבר לאלו שצויינו כבר, הוא במחירה האפסי (על פי רשיון המערכת, ניתן לשכפל אותה באופן חוקי ולגיטימי), ובמגוון התוכנות הגדול הקיים עבורה - בו ניתן למצוא אלטרנטיבה לכמעט כל תוכנת חלונות בשוק.בפורום הזה אנחנו מנסים לעזור למשתמשים חדשים להכנס לעולם הלינוקס, השונה מהותית מעולם החלונות, ולקדם דיונים מקצועיים ברמות שונות, מתוך מטרה לקדם את תפוצת המערכת הנהדרת הזאת (כך לדעתנו) בארץ - הן בשוק הביתי, והן בשוק השרתים האירגוניים.אנו נשמח לעזור בכל שאלה או בעיה.אנא הקפד/י לשמור על כללי השיחה באינטרנט - שפה הולמת, המנעות מפרסומות, המנעות מהפצות, כדי לאפשר לפורום להשאר ברמה הגבוהה בה הוא נמצא עכשיו. כמו כן, מותר שרשור יחיד לכותב בעמוד הראשי, מטעמי נימוס כלפי כותבים אחרים.אולי זה הזמן לעבור ללינוקס?
הוספת הודעה

צרף
תמונה וידיאו קובץ
קבצים המצורפים להודעה

x
הודעה מהנהלת הפורום
0
המשך >>

לצפיה ב-'איך ניתן לדעת כמה CPU צורך פרוסס'
איך ניתן לדעת כמה CPU צורך פרוסס
20/11/2017 | 22:37
1
5
איך ניתן לדעת ב UBUNTU כמה CPU צורך פרוסס? 
עדיפות דרך ה TERMINAL 
שיראה לי ב LIVE כמה אחוזים CPU/RAM הוא צורך
עדיף משהו מובנה בלינוקס אם יש ולא להתקין חבילה נפרדת
תודה
לצפיה ב-'top'
top
21/11/2017 | 07:20
5
דרך אחת היא למצוא את הPID של הפרוסס שמעניין אותך לדוג'
ps aux | grep -v grep | grep myscript
ואז לשרשר אותו ל-top עם הדגל -p
top -p pidnumber
לצפיה ב-'האם אפשר להחזיר גירסה קודמת של פיירפוקס?'
האם אפשר להחזיר גירסה קודמת של פיירפוקס?
17/11/2017 | 12:32
8
53
עדכון שגרתי של לינוקס (xUbuntu 14.04.5) שדרג לי את פיירפוקס מגירסה 56 לגירסה 57. האם אפשר (ואיך) להחזיר את הגירסה הקודמת?
 
תודה.
 
לצפיה ב-'אפשר.'
אפשר.
17/11/2017 | 20:08
7
38
לפני שאתה מתעסק עם זה, אני ממליץ שתתקין דפדפן חלופי, למשל Chromium (מהמאגרים), למקרה שהניסיונות שלך ישביתו את Firefox.
 
ככה, יהיה לך גיבוי כדי שתוכל להמשיך להתייעץ בפורום גם במקרה של תקלה.
 
לגבי גרסה קודמת, קיימות 2 אפשרויות:
1. תוריד את החבילה מפה:
32 ביט:
64 ביט:
 
תתקין אותה בלחיצה כפולה דרך ממשק גרפי, או ע"י פקודה:
sudo dpkg -i package_file_name
כאשר package_file_name זה שם הקובץ שהורדת, כולל נתיב אם המסוף שלך לא פתוח באותה ספריה בה שמרת את הקובץ.
 
אפשרות שניה היא להוסיף את המאגר של מוזילה, ומשם להתקין גרסה 52:
 
היא יותר ישנה, אבל אמורה לזכות לעדכוני אבטחה לזמן מה.
 
אישית, שדרגתי אתמול את הדפדפן בעבודה, והגרסה החדשה אכן זריזה יותר כפי שהם מבטיחים. סה"כ שיפור מאוד נחמד.
 
אני משתמש רק ב-ABP ו-Ghostery בתור תוספים, ושניהם עדיין עובדים עם הגרסה החדשה.
הבנתי שאנשים רבים רוצים לשנמך כי הגרסה שברה חלק מהתוספים - לצערי זה המחיר של המהירות שלה - הם שינו ארכיטקטורה של התוכנה.
 
אם הסיבה שבחרת לשנמך היא תמיכה בתוספים מסוימים, ממליץ לך לעקוב אחרי עדכונים של תוספים אלה, כדי שכאשר הם יעברו התאמה לשיטה החדשה תוכל לשדרג חזרה את הדפדפן.
 
בהצלחה!
לצפיה ב-'הסיבה היא בעיות תצוגה פה ושם'
הסיבה היא בעיות תצוגה פה ושם
18/11/2017 | 10:55
31
ראה, למשל, דף זה. איני יודע איך הוא נראה אצלך, אך על הצג שלי הוא מופיע באותיות זעירות, שלא ניתן להגדילן (בגירסה הקודמת של פיירפוקס היה אפשר). וכן מצאתי שבקובצי pdf מסוימים האותיות בכל מלה צפופות ונדבקות זו לזו (לכך אמנם מצאתי פתרון בשינוי הגדרה, אך השינוי פוגם במראה של דפים אחרים).
 
תודה רבה על התשובה.
אני אשקול אם לחזור לגירסה הקודמת או לוותר.
 
לצפיה ב-'בינתיים ניסיתי'
בינתיים ניסיתי
18/11/2017 | 12:41
5
21
מסתבר שהקובץ שהפנית אליו הוא קובץ עזר כלשהו הקשור להתקנה, שמשקלו 11.6 ק"ב בלבד, ולא חבילת התקנה מלאה. הפעלתו גררה הודעת שגיאה, שקיימת גירסה מתקדמת יותר, ולאחר שהסרתי את גירסה 57 והתקנתי את הקובץ, ניסיון להפעיל את פיירפוקס כשל.
בסופו של דבר התקנתי מחדש את גירסה 57, ונראה לי שאשאר אתה למרות הבעיות (בתקווה שייפתרו בעתיד).
 
תודה.
 
 
לצפיה ב-'הרגע בדקתי את האתר'
הרגע בדקתי את האתר
18/11/2017 | 17:29
4
14
אני לא רועה בעיה (אפשר להגדיל את הפונט אם ctrl +)
עובד ללא בעיה
לצפיה ב-'אני יודע איך מגדילים אותיות'
אני יודע איך מגדילים אותיות
18/11/2017 | 19:41
3
20
אבל אצלי, משום מה, הגירסה החדשה של פיירפוקס אינה מאפשרת זאת בלוח השידורים של כאן11 (וכאמור, יש עוד כמה דפים, שהוצגו בעיוות קל, ומצאתי לכך פתרון סביר, אך לא מושלם).
 
תודה.
לצפיה ב-'בדקתי את האתר גם אצלי, עם FF 57 ב-Ubuntu 14.04'
בדקתי את האתר גם אצלי, עם FF 57 ב-Ubuntu 14.04
18/11/2017 | 20:14
2
24
(כן, אני עדיין על גרסה עתיקה בבית).
 
האתר מוצג תקין, וניתן להגדלה בשיטה הרגילה, אבל:
אצלי, כשניסיתי להגדיל, לקח מספר לחיצות על Ctrl+ לפני שהגודל השתנה.
נראה שהתצוגה מותאמת לרמות זום מסוימות בלבד...
 
לגבי החבילה, אכן לא שמתי לב ונתתי לך קישור לחבילה שגויה מתוך הספרייה.
החבילה הנכונה עם הדפדפן המלא (32 ביט) כאן:
 
וליתר בטחון, 64 ביט כאן:
 
ההבדל בשמות הוא קטן, רק המילה dev שמציינת חבילת פיתוח (כנראה למפתחי הרחבות), ומכאן הבלבול.
 
בהצלחה!
לצפיה ב-'בינתיים מצאתי את הגורם לבעיות התצוגה'
בינתיים מצאתי את הגורם לבעיות התצוגה
18/11/2017 | 22:12
23
היא מכוונת אצלי בקביעות למיקוד טקסט בלבד (Zoom text only). כשביטלתי תכונה זו, הבעיות נעלמו. אבל זה אינו פתרון מבחינתי, כי התכונה הזו חשובה לי (היא מאפשרת להגדיל טקסט בלבד ולשנות בהתאמה את גלישתו בשורות, במקום להאריך אותן), והיא התכונה העיקרית שבזכותה אני מעדיף את פיירפוקס על סלימג'ט (הדפדפן החלופי שלי, שהוא גירסה משופרת של כרומיום ממשפחת כרום).
 
תודה על העדכון. אנסה שוב להחזיר את הגירסה הקודמת מחר או מחרתיים.
לצפיה ב-'מתברר שגם החבילה החדשה אינה מתאימה'
מתברר שגם החבילה החדשה אינה מתאימה
19/11/2017 | 12:37
8
ניסיון התקנה גרר שוב הודעת שגיאה, שאיני זוכר את תוכנה המדויק, אך לפי מה שהבנתי, היא מתאימה לגנום, ולא לשולחן העבודה שלי.
 
בכל אופן, החלטתי להישאר עם הגירסה הנוכחית של פיירפוקס למרות הבעיות הקלות.
 
תודה רבה לך.
לצפיה ב-'שאלה קטנה - '
שאלה קטנה -
13/11/2017 | 13:09
3
32
אני חדש ומתלמד בתחום , אז סליחה אם זה משהו טריוויאלי , או ניסוח לא נכון : 
 
אני רוצה ליצור mount לדיסק ההתקנה של centos , בתוך מכונה וירטואלית של centos .
הcentos הנ"ל מותקן ב minimal installation
 
המכונה הווירטואלית היא kvm ובשביל זה אני יוצר connection בין הדיסק (iso) שנמצא במחשב שלי , לבין הסנטוס - תמונה מצורפת.
 
אבל כאשר אני כותב בטרמינל  df -h , אינני רואה את הדיסק !
 
לעומת זאת , כאשר עשיתי את אותו הדבר במכונה וירטואלית אחרת של centos שמותקנת בהתקנה מליאה עם הGUI , ראיתי את הדיסק על גבי הdesktop  , וגם כאשר עשיתי df -h ראיתי את הדיסק.
 
אני מאמין שהסיבה היא שההתקנה מינימלית ולכן חסרה לי חבילה כלשהיא הדרושה לזיהוי הדיסק הנ"ל , ושאם אני אוסיף אותה אוכל לראות את הדיסק ולעשות לו mount.
יש למישהו רעיון איזו חבילה עלי להוסיף ?
 
תודה רבה.
 
 
 
 
 
לצפיה ב-'לא מכיר את ההתקנה הספציפית של CentOS'
לא מכיר את ההתקנה הספציפית של CentOS
15/11/2017 | 08:38
2
19
אבל נשמע שהבעיה שלך היא שהכונן לא עובר mount אוטומטי.
 
אם אתה רואה את הכונן (ה-ISO) על שולחן העבודה בהתקנה מלאה של המערכת, זה אומר שהוא כבר עבר mount.
מערכות Desktop מודרניות עושות mount אוטומטי למדיות שונות, בד"כ עם fuse.
פקודה df מצגיה מידע על כוננים ומחיצות שכבר עברו mount.
 
התקנה מינימלית כנראה שלא עושה זאת, ועליך לבצע mount בעצמך.
 
ראשית, אתר את הכונן הרלוונטי בתוך dev:
 ~# ls /dev/sd*
 
שנית, צור עבורו נקודת עגינה, למשל כך:
 ~# mkdir /mnt/cdrom
 
שלישית, בצעה את העיגון (נניח שהכונן מיוצג ע"י sdb כי יש רק עוד כונן אחד במערכת):
 ~# mount -o ro /dev/sdb1 /mnt/cdrom
 
את כל הפקודות יש להריץ כ-root.
לצפיה ב-'תודה רבה רבה !!! רץ לנסות. '
תודה רבה רבה !!! רץ לנסות.
16/11/2017 | 20:45
2
לצפיה ב-'עובד , אך לא שורד reboot ...'
עובד , אך לא שורד reboot ...
16/11/2017 | 21:12
12
(כמו כן בתוך הdev היה sr0 ולא sd*)
 
מה שכן בזכות העצה שלך אני כעת יכול להעתיק את הקבצים לתוך איזושהיא ספריה (אני זוכר שאני צריך לעשות mount -o loop לפני זה כדי שאראה את הדיסק כקבצים ולא כדיסק) , ואז אוכל להפוך את הסנטוס הזה לserver , שזו היתה כוונתי הראשונית .....
 
הרגע נזכרתי בעצם שאני יכול להפוך את המאונט לקבוע אם אני כותב לתוך הקובץ fstab , אז בהחלט פתרת לי את הבעיה
 
 
 
לצפיה ב-'אני מחפש כלי ליצירת מצגות מלכידת מסך'
אני מחפש כלי ליצירת מצגות מלכידת מסך
12/11/2017 | 09:49
15

היי.
עד לשנים האחרונות עבדתי עם wink של debugmode.  הכלי מאפשר לכידת מסך ("וידיאו"), ולאחר מכן עריכתה למצגת flash כולל הפסקות, הוספת כתוביות\אלמנטים וכו'.
לצערי הדפדפנים מסירים תמיכה בפלאש.  האם למישהו יש המלצה לכלי אחר לאותה המטרה (ולא, יצירה של וידיאו אמיתי ע"י כלי דוגמת recordMyDesktop לא עוזרת כי אי אפשר ליצור בקלות עצירות יזומות, או להוסיף אלמנטים של "קפוץ אל" או של סימון אזורים במסך).

דוגמה למצגת שנוצרה ע"י הכלי הנ"ל:  http://ddc.co.il/guides/gimp-create-animated-gif.h...

אני צריך כלי שיכול לרוץ גם על לינוקס (שאוכל להתאמן עליו בבית) וגם על חלונות 10 (בעבודה).
 
לצפיה ב-'קבצי VMDK לאחר CLONE של מכונה'
קבצי VMDK לאחר CLONE של מכונה
07/11/2017 | 23:14
27
עשיתי FULL CLONE של מכונה - לא יודע אם היו בה סנפשוטים.
עכשיו אני רואה שיש לי בתיקיה של המכונה מספר קבצי VMDK כל 1 מהם שוקל 4-5 גיגה והשמות שלהם מסתיימים ב S001 S002 וכו'
אני לא רואה בהגדרות של ה VM שקיימים למכנה שלי כרגע סנפשוטים
מה הקבצים האלה
והאם אפשר למחוק אותם איכשהו
תודה
לצפיה ב-'בעיה בהתקנה באמצעות git בלינוקס.'
בעיה בהתקנה באמצעות git בלינוקס.
27/10/2017 | 17:58
1
135
היי,
 
אני מנסה להתקין ב-centos רכיב מ-git (שאגב, הצלחתי ב-centos בסביבה אחרת).
לאחר הנ"ל אני מקבל הודעת שגיאה:
 Cloning into 'kerberos'...
fatal: Unable to find remote helper for 'https'
לפי המלצות מהאינטרנט, ניסיתי לבצע את הפעולות הבאות:
 $ yum install curl-devel
$ # cd to wherever the source for git is
$ cd /usr/local/src/git-1.7.9  
$ ./configure
$ make
$ make install
אך לא ברור לי איפה הספריה של ה-git שמכילה את ה-configure.
 
הפעולות+תוצאות:
 >git --version
git version 2.1.2
//=======

>whereis git
git: /usr/bin/git /usr/local/bin/git /usr/local/git /root/bin/git /usr/local/git/bin/git /usr/share/man/man1/git.1.gz /usr/src/git-2.9.3/git.o /usr/src/git-2.9.3/git.rc /usr/src/git-2.9.3/git /usr/src/git-2.9.3/git.c /usr/src/git-2.1.2/git.o /usr/src/git-2.1.2/git.rc /usr/src/git-2.1.2/git /usr/src/git-2.1.2/git.c

>which git
/usr/local/bin/git
גם התקנה מחדש + install לא העלתה חרס.
 yum erase git
yum remove git
yum install git
 
 
גם המליצו פקודה נוספת:
 
 ~/libexec/git-core/git-remote-https https://github.com/mongodb-js/kerberos.git
הפקודה הנ"ל תקועה.
 
כל מה שניסיתי - לא הצלחתי להתקין את הרכיב ב-git (כנראה בשל https, וניכר כי כל נתיב של https שאנסה - אתקל באותה הבעיה. גם הצלחתי להתקין בשרת centos אחר).
 
איך בכל זאת אפשר להעלות את הנ"ל?
 
תודה.
לצפיה ב-'GitHub מאפשר להוריד את הפרויקט כ-zip.'
GitHub מאפשר להוריד את הפרויקט כ-zip.
28/10/2017 | 12:24
23
אתה נכנס לעמוד הזה:
 
לוחץ "Clone or download", ובוחר "Download ZIP".
 
שים לב, ש-git הוא כלי ניהול תצורה של קוד.
מה שירד לך ב-zip, ומה שהיה יורד לך לו הפקודה clone היית מצליחה, זה ספרייה עם קוד מקור של הפרויקט.
 
יהיה עליך לבנות את הקבצים הבינאריים מקוד, ולמקם אותם במקומות נכונים במערכת כדי להשתמש בהם.
 
בהצלחה!
לצפיה ב-' מחכים לכם בפורומים תיירותיים חדשים '
מחכים לכם בפורומים תיירותיים חדשים
16/10/2017 | 15:50
2
 
מתכננים טיול בחו"ל
רוצים להתייעץ עם מדריך טיולים שייתן לכם את כל הטיפים השווים
 
אתם מוזמנים לפורומים החדשים שלנו 
 
פורום חדש על המדינות הבלטיות לתכנן טיול בצפון-מזרח אירופה
 
בואו לברר על האטרקציות הכי שוות בפורום טיולים באירופה
 
הודו, נפאל, הפיליפינים... אתם מוזמנים לפורום המזרח הרחוק לשאול הכל
 
טיול לכבוד הפנסיה? טיול אחרי צבא? ירח דבש? הכל בפורום דרום ומרכז אמריקה
 
רואים רק לבן בעיניים? פורום חופשות סקי הוא הפורום שלכם
 
 
המשך גלישה נעימה
לצפיה ב-'האם אפשר לחלץ קבצים מקובץ ארכיון exe בלינוקס?'
האם אפשר לחלץ קבצים מקובץ ארכיון exe בלינוקס?
13/10/2017 | 11:32
9
146
אם כן, איך (ב- xUbuntu 14.04, וכוונתי לקובץ שדחוסים בו קבצים אחרים, כמו קובץ zip, אך שהסיומת שלו היא exe)?
 
תודה.
 
 
לצפיה ב-'7zip'
7zip
15/10/2017 | 07:43
7
29
בחלק ניכר מהמקרים, הקבצים הללו נדחסים באמצעות כלי self extract של winrar, winzip ודומיהם, ולכן הם קובץ דחוס סטנדרטי, שמצורף אליו יישום שמטרתו לפרוס את הקובץ ברישא. תוכנות דוגמת 7zip יצליחו להתמודד עם רוב המופעים של קבצים דחוסים בתבניות נפוצות.
לצפיה ב-'תודה רבה לשניכם, אך לצערי'
תודה רבה לשניכם, אך לצערי
15/10/2017 | 08:54
6
42
ניסיתי, זה אינו פועל.
לצפיה ב-'אתה בטוח שמדובר בקובץ דחוס?'
אתה בטוח שמדובר בקובץ דחוס?
15/10/2017 | 22:33
5
23
אתה יכול גם להתקין wine ולנסות להריץ את ה-EXE כדי שיחלץ את עצמו.
לצפיה ב-'מדובר בקובץ שדרוג לקושחת טלוויזיה'
מדובר בקובץ שדרוג לקושחת טלוויזיה
16/10/2017 | 09:29
4
28
שנמצא כאן. לפי מה שהבנתי ממדריך השדרוג, יש להעתיק את הקובץ להחסן נייד (דיסק-און-קי), ללחוץ עליו לחיצה כפולה, ואחר כך על "התקן", ואז יחולצו ממנו קבצים אחרים (כדי להגיע למדריך השדרוג, וצריך להבדיל בינו לבין המדריך למשתמש, צריך ללחוץ על "מידע נוסף", מתחת ל"קובץ שדרוג”).
אולי באמת הקובץ המסוים הזה אינו קובץ דחוס. האם אפשר לדעת זאת מראש בלי להפעילו?
ושאלות אגב (שאינן מנושאי הפורום): מה בדיוק התועלת שבעדכון הקושחה? מה היתרונות שבו? עד כמה הוא רצוי, ובאילו סיכונים הוא כרוך? לא מצאתי מידע על כך וחשבתי, שאולי הוא יימצא באחד הקבצים שיחולצו.
ולגבי Wine, הורדתי אותה בעבר והתאכזבתי, ועל כן הסרתי אותה. אולי אתקין ואנסה שוב (ניסיתי גם להפעיל את הקובץ ב- Windows 98 וקיבלתי הודעה, שהוא מיועד לגירסה מתקדמת יותר).
תודה רבה לך.
 
לצפיה ב-'כמה דברים:'
כמה דברים:
16/10/2017 | 13:47
3
24
1. ברירת מחדל היא שקבצי EXE אינם קבצים דחוסים. אלה קבצי תוכנה שנועדו לרוץ.
תוכנות דחיסה כמו ZIP ו-RAR עושות סוג של קומבינה כשהן הופכות ZIP או RAR ל-EXE, וכלים בלינוקס יודעים לדלג על חלק של התוכנה ולראות את החלק שהוא סתם קובץ דחוס.
 
2. אפשר לפתוח את הקובץ הספציפי שאתה מעוניין בו ע"י Archive Manager של Ubuntu.
(לחיצה ימנית בסייר קבצים מציע את זה ברירת מחדל)
זו למעשה סתם תוכנת ממשק שמאגדת תוכנות דחיסה מסוגים שונים כולל ZIP ו-RAR.
אני לא בטוח מה המקבילה שלה ב-xUbuntu, ואני לא בטוח אם איזה כלי היא פתוחת את הקובץ.
לדעתי תוכל להתקין אותה אצלך מהמאגרים (כלומר מהחנות).
נסה לחפש "Archive Manager" או "File Roller".
 
אגב, ניסית בכלל לחיצה ימנית על הקובץ, ולראות איך המערכת מציע לפתוח אותו?
 
3. הטלוויזיה שלך היא בעצם מחשב.
יש לה מערכת הפעלה ותוכנות.
 
עדכון קושחה (firmware) הוא שדרוג למערכת הפעלה ו\או תוכנות אלה.
 
בניגוד למחשב רגיל טלפונים, טלוויזיות, וכו' לא מאפשרים סתם ככה לשנות קבצים במערכת, אלא מקבלים עדכונים דרך קבצים מיוחדים שהיצרן הכין.
 
4. כדי לדעת מה מביא קובץ שדרוג מסוים צריך למצוא ולקרוא "release note" רשימת שינויים שבד"כ מצורפת לעדכונים כאלה.
בדומה לרשימת שינויים שעדכונים ב-Windows או Ubuntu מציגים לך לפני שאתה בוחר להתקין אותם.
 
לא יודע היכן Samsung מציגה את המידע הזה אם בכלל.
 
5. אם הטלוויזיה שלך עובדת לשביעות רצונך, אתה לא חייב לבצע עדכון.
אם יש בעיות, ייתכן שהעדכון מתקן אותן, כפי שעושים עדכונים למערכת הפעלה במחשב.
 
הסיכון בעדכון הוא, שאם תקרה תקלה - למשל, תהיה הפסקת חשמל בדיוק בזמן שהעדכון מתבצע, הטלוויזיה תתקלקל (כי התוכנה שמפעילה אותה תהיה מבולגנת), ולא תעבוד יותר.
 
תלוי בסוג התקלה בדיוק, ייתכן שהיא תפתר ע"י הרצה חוזרת של העדכון, וייתכן שלא.
 
התהליך דומה במידה מסוימת לעדכון BIOS במחשב, אם יצא לך להתעסק עם זה.
לצפיה ב-'ודאי ניסיתי'
ודאי ניסיתי
16/10/2017 | 15:20
2
21
אכן, פתיחת הקובץ באמצעות Archive manager היא ברירת המחדל, אבל ניסיון הפתיחה מציג הודעת שגיאה: An error occurred while loading the archive.
וכן, עדכנתי בעבר, לפני כעשור, את הביוס של המחשב הישן שלי (זה שיש בו גם Windows 98 SE וגם Ubuntu 10.04 וגם xUbuntu 14.04), והוא עובד כמו חדש עד היום (אמנם לפני כשנה הוא עשה סימני גסיסה, אך הוא חזר לחיים אחרי ניתוח השתלת ספק).
ותודה רבה על תשובתך, שהיא, כרגיל, ברורה, מושקעת, ובעיקר מקצועית.
 
לצפיה ב-'נסה להוריד שוב את הקובץ.'
נסה להוריד שוב את הקובץ.
16/10/2017 | 16:02
1
24
אצלי על Ubuntu 16.10 לא היית בעיה לפתוח אותו עם התוכנה הזו.
יכול להיות שהקובץ אצלך לא ירד תקין.
 
אפשרות אחרת היא שחסרה לך איזו תוכנת דחיסה שבה משתמש ה-manager או שהגרסה שלו ישנה מידי (בספק).
לצערי, כאמור אני לא בטוח לגבי סוג הדחיסה הספציפית בו משתמשים במקרה הזה, אז אני לא יכול לייעץ לך מה להתקין.
 
אתה יכול לנסות להריץ את הפקודה file-roller מהמסוף (זו כאמור אותה תוכנה), ולראות אם הוא מדפיס שם מידע נוסף על השגיאה.
לצפיה ב-'החלטתי לוותר על העדכון, תודה'
החלטתי לוותר על העדכון, תודה
16/10/2017 | 21:30
8
לצפיה ב-'התקנת דרייבר מהרשת '
התקנת דרייבר מהרשת
08/10/2017 | 19:08
5
39
שלום.
לאחרונה התקנתי במחשב הנייד הישן שלי, מערכת KUBUNTU.
התוכנה די מוצאת חן בעיניי, אבל היה ברור לי שאין שום דרייבר גראפי שמותקן.
הקלקתי על EXTRA DRIVERS, וצוין שם שאין שום צורך בדרייברים קנייניים או משהו בנוסח דומה. אבל זה כמובן לא נכון, מפני שכל פריטי המ"ה היו גדולים במיוחד, והיה ברור שצריך דרייבר חיצוני כלשהו.

מדובר בכרטיס גראפי מסוג SIS M661. ולא ברור לי אם בכלל קיים דרייבר לינוקס מכל סוג לכרטיס הגראפי הזה.
איך שלא יהיה, זה מעניין אותי לדעת איך מתקינים דרייבר שהורד מהרשת או הוסף בעזרת USB.
אפשר לקבל איזו תגובה או הסבר לגבי התקנת דרייבר חיצוני?
לצפיה ב-'כמה הסברים:'
כמה הסברים:
10/10/2017 | 18:13
3
25
1. זה שהכל "גדול מידי" אינו בהכרח אינדיקציה שאין דרייבר.
אולי אתה פשוט צריך לכוון את הרזולוציה.
אני לא זוכר איך נראית תוכנת ההגדרות ב-Kubuntu (אני משתמש בממשק שונה), אבל אם תחפש בתפריט משהו כמו Display או System Settings בוודאי תמצא.
 
אם אינך יכול להגדיל את הרזולוציה דרך הגדרות, אז באמת צריך לחפש דרייבר שונה.
 
2. extra drivers אומר שימוש בדרייברים לא חופשיים, בד"כ של היצרן.
זה לא נחוץ עבור כל הכרטיסים, למשל, ל-Intel יש תמיכה מצוינת בלי זה.
Kubuntu מגיעה עם הרבה דרייברים חופשיים מובנים.
 
אבל, נראה שהכרטיס שלך לא מבוסס Intel.
גיגול מהיר מראה שמצב התמיכה בו בעייתי, אבל לפני שנמשיך לפתרון בוא ננסה קודם כל לוודא מה באמת יש במחשב שלך:
פתח מסוף וכתוב את הפקודה הבאה:
 lspci -nn
 
תדביק פה את הפלט שיצא.
 
3. יש כל מיני דרכים להתקין דברים ב-Kubuntu.
בגדול, אם יש לך חבילת deb (כלומר קובץ עם סיומת deb) לחיצה כפולה עליו תפתח את תוכנת ההתקנה.
אם מצאת דרייבר שמסופק בקובץ מסוג אחר, שיטת ההתקנה תלויה בסוג הקובץ.
זה יכול להיות קובץ ריצה (כמו EXE) ואז צריך להריץ אותו (כנראה עם sudo), או זה יכול להיות קובץ tar.gz או tar אחר כלשהו שזה קובץ דחוס שיש לפרוס (כמו rar).
 
בד"כ המקום שסיפק לך את הקובץ (למשל אתר של יצרן הכרטיס או המחשב) אמור לספק הוראות שימוש בו.
לצפיה ב-'בינתיים הסרתי את המע''
בינתיים הסרתי את המע'
10/10/2017 | 18:27
2
22
חשבתי כבר שלא אקבל תשובה.
 
כל זמן שהקובונטו היה מותקן במחשב שלי, הגעתי אל דף עם אפשרויות רזולוציה, אבל לא הצלחתי לשנות את הרזולוציה הנמוכה. זה היה אזור "רדום".
 
מה שלא ציינתי- כל זמן שהרצתי את קובונטו כ LIVE CD, הכל היה נראה בסדר, אבל היה אטי להחריד.
כשהתקנתי את קובונטו על הדיסק הקשיח, המהירות תפעול נהייתה בסדר, אבל הרזולוציה הפכה לנמוכה במידה רבה מדי וחלק מהפריטים נראו די גדול.
התפריט התחל של קובונטו היה די גדול ותפס את מלוא גובה המסך.
 
כעת אני כבר לא יכול להריץ פקודות מפני שהסרתי את ההתקנה.
 
תודה על התשובות.
לצפיה ב-'טוב, הפורום הזה לא פעיל במיוחד...'
טוב, הפורום הזה לא פעיל במיוחד...
10/10/2017 | 18:32
1
22
מוזר.
אם ה-LiveCD מצליח להריץ את הדרייבר הנכון, אין סיבה שמערכת מותקנת לא תמצא ותשתמש בו.
זה טבעי שה-LiveCD יעבוד לאט בגלל שקריאה מ-CD אטית יותר מקריאה מהארד דיסק, וגם המידע על ה-CD דחוס.
 
אם בכל זאת תרצה להתנסות עוד, תוודא שאתה משתמש בגרסה הכי אחרונה.
תמיכה בדרייברים שונים משתפרת מגרסה לגרסה.
אם לקחת גרסה ישנה מתוך מחשבה שכמו ב-Windows היא תהיה קלה יותר עבור מחשב ישן, אז זו טעות.
לצפיה ב-'זה היה קובונטו 17.10'
זה היה קובונטו 17.10
10/10/2017 | 20:24
11
לצפיה ב-'היה לי משהו דומה עם אובונטו'
היה לי משהו דומה עם אובונטו
26/10/2017 | 12:38
11
אני רק מעדכן שהיה לי משהו דומה עם אובונטו 17.10.
אכן, היה מותקן דרייבר לינוקס כלשהו לכרטיס מסך שאובונטו לא מזהה.
לא הייתה אפשרות לשנות את הרזולוציה הנמוכה של המערכת.
עיינתי בפורומים אחרים של לינוקס והבנתי שאפשר לסדר את זה דרך הטרמינל. אבל זה נראה לי מסובך מדי עבורי.
לצפיה ב-'סיוע במחקר קטן בלינוקס '
סיוע במחקר קטן בלינוקס
10/10/2017 | 17:26
1
56
שלום,
אני מבצע מחקר על משחוק בלינוקס , אשמח אם תוכלו לעזור לי ולהשתתף פה ועל הדרך תתרגלו את השפה.
 
תודה לכולם!
לצפיה ב-'מי מה מו?'
מי מה מו?
10/10/2017 | 18:04
38
אתה מצפה מאנשים שירשמו לאתר שלך עם מייל או חשבון אחר קיים, אבל לא מספר כלום עליו.
 
לא מי אתה ואיזה מחקר אתה מבצע - שזה א-ב כשעושים מחקר עם אנשים, בנוסף להסבר ברור אלו נתונים אתה אוסף, כיצד תשתמש בהם ומי יראה אותם.
 
אבל אפילו לא מה בעצם יש באתר.
מה זה "משחוק"?
אתה מנסה לחקור באלו משחקים אוהבים לשחק אנשי לינוקס?
או אתה חוקר איך לפתח משחקים ללינוקס?
איזו שפה בדיוק אמורים לתרגל?
האם התכוונת ליצור לומדה כלשהי?
לצפיה ב-'הגדרת firewall ב-centos'
הגדרת firewall ב-centos
07/10/2017 | 13:01
34
אני ביצעתי לא מעט התקנות בשרת centos.
ה-firewall לא פתוח להכל, אלא למחשב ספציפי (שרת windows הנמצא באותה החווה).
מעת לעת, אני צריך לפתוח firewall לפורטים מסויימים.
עד כה לא היתה כלל בעיה (הפורטים היו פתוחים, והצלחתי לעשות בדיקה באמצעות ה-telnet).
 
מסיבה לא ברורה, לאחרונה אני לא מצליח לפתוח שום port נוסף בשרת.
 
הפקודה שבדר"כ אני מריץ:
 firewall-cmd --zone=windowszone --add-port=8000 --permanent
firewall-cmd --reload
הפקודות הנ"ל עוברות בהצלחה, אולם כשאני מנסה באמצעות ה-telnet בשרת ה-windows (וזה משהו רק לאחרונה), אני מקבל הודעה:
 Connecting To <MYIP>... Could not open connection to the host, on port <MYPORT>
ניסיתי לבדוק מהות של firewall-cmd (שהשתמשתי בו במקום פקודה של iptables) והבנתי שמאחוריי הקלעים יש קריאה ישירות לפקודות של iptables.
 
פקודה:
 iptables --list-rules
 
אני מקבל את הרשימה (חלקית, זה קצת ארוך  ...), אך נראה שזה הרלוונטי:
 -A IN_windowszone -j IN_windowszone_log
-A IN_windowszone -j IN_windowszone_deny
-A IN_windowszone -j IN_windowszone_allow
-A IN_windowszone -p icmp -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 2181 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 3306 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 8005 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 9092 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 6379 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 22 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 9006 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 8001 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 80 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 81 -m conntrack --ctstate NEW -j ACCEPT
-A IN_windowszone_allow -p tcp -m tcp --dport 82 -m conntrack --ctstate NEW -j ACCEPT
(אחרי ה-22, זה סתם נסיונות ...)
נראה שהסדר שה-iptables מציג השתבש.
 
הדבר היחיד (לא יודע אם קשור), שראיתי חוסר מקום ב-kernel לאחר עדכון גירסה, אז עדכנתי גירסה של kernel (תוך הסרת ישן).
 df -H /boot 
בדקתי מקום בדיסק...
rpm -qa | grep kernel
rpm -e <list of old versions>
yum -y update kernel
ואח"כ reboot - הכל עבד כרגיל.
 
תודה.
לצפיה ב-'תווים בעברים בלינוקס'
תווים בעברים בלינוקס
19/09/2017 | 15:33
3
57
שלום,
 
איך אני מוסיף תמיכה לתווים בעברית במערכת לינוקס ב-terminal?
למשל, כשאני מנסה לרשום ב-terminal תווים בעברית, פשוט העורך מחליף את התווים ברווחים.
יש אגב מצבים שמערכת נתקעת, או לא עובדת אם אני כותב בעברית.
ב-python (שאגב, אני רואה רווחים במקום בעברית בדוגמה להלן)
 print אבג
בתכלס אני רואה
 print
ובהודעת שגיאה אני מקבל:
  File "<stdin>", line 1
   print
         ^
SyntaxError: invalid syntax
ב-ubuntu וב-centos.
 
תודה.
לצפיה ב-'תלוי בטרמינל'
תלוי בטרמינל
19/09/2017 | 20:35
2
53
לינוקס מינט:
 
לצפיה ב-'איך הגדרת את הלינוקס.'
איך הגדרת את הלינוקס.
29/09/2017 | 13:11
1
30
זה משהו בהגדרה של תמיכה בעברית, אם כך.
איך אפשר להגדיר תמיכה גם בערכים בעברית (כנראה, זה לא ה-default).
לצפיה ב-'האמת, לא עשיתי משהו מיוחד בהגדרות'
האמת, לא עשיתי משהו מיוחד בהגדרות
29/09/2017 | 13:27
24
ושפת הממשק אצלי היא בכלל אנגלית.
לצפיה ב-' שנה טובה וחג שמח '
שנה טובה וחג שמח
19/09/2017 | 14:14
3
 
חג שמח לגולשי האתר
 
שנה טובה ומתוקה
שכולנו נכתב ונחתם לחיים טובים ולשלום 
 
בברכה 
לצפיה ב-' מומחים חדשים מחכים לשאלות שלכם '
מומחים חדשים מחכים לשאלות שלכם
12/09/2017 | 12:56
7
 
מומחים ואנשי מקצוע חדשים מחכים לכם בפורומים הבאים 
 
 
בפורום משפט פלילי תוכלו לשאול הכל על התחום ולקבל תשובות מעו"ד מומחה

בפורום טיפול זוגי תוכלו להתייעץ ולשתף בבעיות בזוגיות או בבניית זוגיות
 
בפורום ריפוי ותזונה טבעית תוכלו לדעת איך לרפא את גופכם בעזרת תזונה ואורח חיים בריא

בפורום השקעות נדל"ן בקנדה תוכלו להתייעץ לגבי כל סוגי ההשקעות עם עו"ד ישראלי וקנדי

בפורום שמאות מקרקעין תוכלו לשאול על מיסוי נדל"ן, תכנון ובנייה, תביעות מקרקעין ועוד

בפורום נזקי גוף ותאונות דרכים תוכלו לקבל ייעוץ משפטי לגבי כל סוגי נזקי הגוף והתאונות

בפורום אוטיזם- גישה ביו רפואית תוכלו לדעת איך מפחיתים את התסמינים של אוטיזם לפי עקרונות הרפואה המשלימה

בפורום מכירות ופיתוח עסקי תוכלו לשאול על מכירות b2b, פיתוח עסקי, הגדלת רווחים ועוד

בפורום משפחות מורכבות תוכלו לשתף ולהתייעץ בהכל אם אתם נמצאים בפרק ב' מעט מורכב 
 
בפורום דרכון פורטוגלי ידברו אתכם על הוצאת דרכון ואזרחות פורטוגלית-אירופאית
 
 
גלישה נעימה
 
לצפיה ב-'"רק מניח את זה פה" ...'
"רק מניח את זה פה" ...
04/09/2017 | 13:15
6
119
לצפיה ב-'bad timing '
bad timing
04/09/2017 | 18:39
2
76
i will be on UA91 today
next year you need to call me before seting the date :)
לצפיה ב-'הליצנים שכחו לברר איתך מתי אתה יכול?'
הליצנים שכחו לברר איתך מתי אתה יכול?
04/09/2017 | 22:52
1
57
אם הבעיה היא מקום לשהות בארץ לעוד לילה או שניים (כולל הילדים והאישה) - אתה מוזמן.  (הוד השרון, כולל טרמפ לרכבת וחזרה).
לצפיה ב-'just land'
just land
05/09/2017 | 15:36
47
get work today :)
לצפיה ב-'מחר ... ב-7 בחודש.'
מחר ... ב-7 בחודש.
06/09/2017 | 09:13
19
לצפיה ב-'אפשר פרטים?'
אפשר פרטים?
07/11/2017 | 23:33
1
3
מטעם מי הכנס הזה?
היכן נרשמים?
מה העלות?
תודה
לצפיה ב-'כדאי אולי לגגל את הנושא - "אוגוסט פינגווין"'
כדאי אולי לגגל את הנושא - "אוגוסט פינגווין"
08/11/2017 | 06:55
4
הכנס הוא הכנס השנתי של משתמשי קוד פתוח, המארגנים הם עמותת "המקור" (עמותה לקוד פתוח).  
 
נרשמים - השנה כבר אי אפשר להרשם (הכנס היה לפני כחודשיים), אבל כעקרון ניתן להרשם באתר הכנס או ישירות להגיע ולהרשם.  
 
עלות - השנה העלות היתה 100 ש"ח עבור שני ימי הכנס.
 
על לא דבר.
לצפיה ב-'עזרה עם mount של דיסק מוצפן בזמן עליה'
עזרה עם mount של דיסק מוצפן בזמן עליה
02/09/2017 | 14:31
2
59
קניתי דיסק חדש, חיברתי, רציתי שיהיה מוצפן, מצאתי מדריך שהרגיש לי הגיוני, פעלתי פחות או יותר לפיו. בגדול הכל עובד, חוץ מדבר אחד: בעליית המחשב זה נתקע, במקום לשאול אותי סיסמה. המחשב עולה רק אם אני סוגר את זה בהערות בקובץ fstab.
אני חושב שאני אמור להוסיף משהו בצורה ידנית לקובץ etc/cryptfs/ אבל אני לא ממש מבין מה זה אמור להיות. אשמח אם תוכלו לעזור לי.
המדריך שלפיו פעלתי נמצא כאן:
https://www.linux.com/blog/how-full-encrypt-your-linux-system-lvm-luks
 
למען ההבהרה, את ההצפנה ביצעתי לפני שהגדרתי עליו LVM.
להלן רצף הפקודות שעשיתי:
cryptsetup luksFormat --hash=sha512 --key-size=512 --cipher=aes-xts-plain64 --verify-passphrase /dev/sdb
cryptsetup luksOpen /dev/sdb crypt
pvcreate /dev/mapper/crypt
vgcreate vgcrypt /dev/mapper/crypt
lvcreate -n lvswap -L 10G vgcrypt
lvcreate -n lvdata -L 1536G vgcrypt
mkswap /dev/vgcrypt/lvswap -L LVSWAP
swapon /dev/vgcrypt/lvswap
mkfs.xfs -f /dev/vgcrypt/lvdata
mount /dev/vgcrypt/lvdata /data
לצפיה ב-'crypttab'
crypttab
16/09/2017 | 06:12
1
27
אתה צריך לעגן את המחיצה ב crypttab
 
 
 
תסתכל ספציפית על חלק 4 ו-5.
לצפיה ב-'ובכן...'
ובכן...
19/09/2017 | 16:35
16
קודם כל תודה רבה! זה אכן עובד. בדקתי עכשיו.
אבל! זה קצת חוטא לכל הרעיון של דיסק מוצפן. כי בעצם פותחים אותו בעזרת קובץ שנמצא על המחשב בצורה לא מוצפנת, ומשתמשים בו בתור סיסמה אוטומטית, אם אני מבין נכון. אז... מה זה עוזר לנו, נגיד, למקרה שהמחשב נגנב? הרי זו הסיבה העיקרית שבגללה אני מצפין. אז מה עשינו בזה? הייתי מעדיף שבזמן העליית מערכת ההפעלה היא תשאל אותי את הסיסמה! אין אפשרות כזאת?
לצפיה ב-'מהו ה- generic וכיצד מעדכנים אותו ב- xUbuntu 14.04.5'
מהו ה- generic וכיצד מעדכנים אותו ב- xUbuntu 14.04.5
29/08/2017 | 10:09
6
40
במחשב החדש שלי, 64 ביט, מותקן xUbuntu 14.04.5 עם 4.4.0-93 generic.
במחשב הישן שלי, 32 ביט, מותקן xUbuntu 14.04.5 עם 4.4.0-91 generic.
עד גירסה 4.4.0-91 העדכונים היו תואמים בשני המחשבים.
אני תוהה אם 4.4.0-91 זו הגירסה האחרונה ל- 32 ביט, או שמא קיימת בעיה כלשהי במחשב הישן שלי, שמונעת עדכון לגירסה מתקדמת יותר, והאם זה חשוב בכלל.
אעיר, שלאחר העדכון ל- 4.4.0-91 (במחשב הישן) הייתה הגלישה בפיירפוקס איטית, וחשדתי שהבעיה בעדכון. על כן הסרתי והתקנתי אותו מחדש באמצעות synaptic package manager. הייתכן שזו הסיבה לכך שהגירסה אינה מתעדכת עוד?
כדי להסיר ספק: ניסיתי לעדכן כמה פעמים באמצעות software updater וכן מהמסוף (sudo apt-get upgrade). העדכונים מגיעים, למעט גירסת ה- generic.
 
לצפיה ב-'מה שכתבת נראה כמו חלק מתיאור גרסה של ה-kernel'
מה שכתבת נראה כמו חלק מתיאור גרסה של ה-kernel
30/08/2017 | 09:26
5
26
ה-kernel הוא הבסיס של המערכת - הרכיב שמדבר ישירות עם, ונהל את חומרת המחשב שלך.
 
ההבדל בגרסאות הוא הבדל מינורי, שאינו מציין שינוי בפיצ'רים או אפילו בתיקוני אבטחה וכו'.
(כדי להבין מה הוא כן מציין, אם בכלל, צריך לחפור עמוק בתיעוד).
 
היות וחומרה של שני המחשבים שלך שונה מאוד, הגיוני ביותר שמספרי הגרסה של ה-kernel יהיו מעט שונים.
 
הסיכוי שהעדכון המדובר הוא זה שגרם לאטיות ב-FF הוא נמוך ביותר.
באופן אישי אני חווה לפעמים תקיעות של FF מזה 2 - 3 עדכונים של FF עצמו, במספר מחשבים, כך שכנראה מדובר בבאג שהם עצמם הכניסו, ויש לקוות שיטופל בקרוב (אני אצלן מכדי לחפור או להתערב בנושא).
 
התקנת חבילה דרך synaptic אינה מונעת עדכונים שלה, אלא אם אתה מבצע ספציפית פעולה מיוחדת של "נעילת חבילה".
אני אפילו לא זוכר אם לסינפטיק יש ממשק לבצע את זה, אבל בכל מקרה אם פשוט התקנת לא סביר שזה קרה.
 
זכור שבסוף סינפטיק ו-software updater כולם רק ממשקים שמשתמשים ב-apt מאחורי הקלעים, אז לכל היותר יהיה הבדל ברשימת התוכנות שהם מציגים לך, אבל לא בגרסאות שהם מתקינים.
לצפיה ב-' רבה'
רבה
30/08/2017 | 11:12
4
לצפיה ב-'שאלת אגב: איפה רשום מספר הגירסה?'
שאלת אגב: איפה רשום מספר הגירסה?
01/09/2017 | 14:15
3
12
באיזה קובץ רשום מספר הגירסה של מערכת ההפעלה, לדוגמה:
xUbuntu 14.04.3.
אני יודע את מספר הגירסה לפי קובץ ההתקנה, אבל אני יודע גם, שהמספר הזה משתנה במרוצת הזמן עקב עדכונים מהרשת.
 
תודה.
 
לצפיה ב-'גרסת המערכת רשומה בקובץ etc/lsb-release/'
גרסת המערכת רשומה בקובץ etc/lsb-release/
01/09/2017 | 14:40
2
21
אם אתה רוצה עוד פרטים על ה-kernel ספציפית, יש את הפקודה uname -a
לצפיה ב-'תודה רבה על ההפניה לקובץ'
תודה רבה על ההפניה לקובץ
01/09/2017 | 17:26
1
23
בדיוק מה שחיפשתי.
תודה גם על הפקודה, אך לא הבנתי מה בדיוק צריך לרשום במסוף; ניסיתי כמה צירופים (למשל: sudo apt-get uname -a), אך בכולם קיבלתי הודעת שגיאה.
 
לצפיה ב-'בסדר, הבנתי (בלי apt-get)'
בסדר, הבנתי (בלי apt-get)
01/09/2017 | 17:48
22
ניסיתי גם קודם בלי apt-get, אך כנראה טעיתי בהקלדה.
 
תודה רבה.
לצפיה ב-'שאלה בנושא עידכון מינט'
שאלה בנושא עידכון מינט
27/08/2017 | 23:22
1
45
ה- update manager של לינוקס-מינט שאל אותי כשהתקנתי איך אני רוצה לנהל עידכונים. היו שם שלוש אופציות, אחת להציע עדכוני אבטחה בלבד, השניה להציע את כל העדכונים וולתת לי לבחור, השלישית לעדכן הכל כל הזמן. היה כתוב שהאפשרות השניה מומלצת לארוב המשתמשים, ואני, האמת, לא רוצה לחשוב יותר מדי על עדכונים, אז בחרתי בה.
עכשיו הנה העניין - יש רשימת עדכונים והוא אכן מציע לי את כולם ונותן לי לבחור, אבל אין לי מושג מה לבחור ואני לא ממש רוצה לחשוב על זה. אז האם אני בתור משתמש "עצלן" יכול בבטחון מלא לעבור לאפשרות השלישית ולתת לו לעדכן הכל, או שזה אכן מסוכן פוטנציאלית ומיועד רק למשתמשים מנוסים כמו שכתוב שם? ואם אני נשאר באפשרות השניה, איך לדעת מה לבחור ומה לא? בגדול זה מיני-מחשב שאני משתמש בו לגלישה ומדיה.
לצפיה ב-'אתה יכול לבטוח ברשימת העדכונים שהוא מציע'
אתה יכול לבטוח ברשימת העדכונים שהוא מציע
28/08/2017 | 08:50
29
בד"כ כשמדובר ביישומים המסומנים בירוק וממוספרים, עד כמה שזכור לי, בספרה 1, אין שום בעיה לעדכנם.
לצפיה ב-'שמירת סיסמה לאתר אחד בלבד + פרסומות קופצות'
שמירת סיסמה לאתר אחד בלבד + פרסומות קופצות
20/08/2017 | 07:49
4
31
שלום שלום,

אני לא מבינה גדולה במחשבים, יש לי שאלות פשוטות לגבי דפדפן פיירפוקס:
1. אני לא רוצה שישמרו סיסמאות, למעט לאתר אחד. יש אפשרות לעשות את זה, סוג של exception?
2. עולות לי פרסומות בחלונות קופצים. כן, התקנתי כבר adblock, adblock plus ועוד ועוד. עדיין עולים, והחידוש של השנה האחרונה הוא שהן עולות כ-tab נוסף בדפדפן ומקפיצות את הדף שפתחתי בפועל טאב קדימה.
3. תוכלו להסביר לי מה זה cookies והאם אני רוצה את זה או לא? מצד אחד - אם הבנתי נכון, באחד הדפדפנים (אופרה בחלונות) זה לא עוקב לי אחרי ההיסטוריה של יוטיוב, שזה טוב. אבל יש כל מיני דברים שלא נפתחים לי כי "your browser does not accept cookies" או משהו כזה.

תודה רבה ושיהיה יום נהדר,
אשרה.
לצפיה ב-'כמה תשובות:'
כמה תשובות:
21/08/2017 | 15:13
3
29
1. לא, אפשר לעשות exceptions רק הפוך - אתרים שעבורם לא ישמרו ססמאות.
אבל בכל פעם שהדפדפן מבקש לשמור ססמה עבור אתר מסוים, אפשר לומר לו לא לשמור וגם לא לבקש שוב עבור האתר הזה.
 
2. יש הרבה שיטות להקפיץ פרסומות ותרם פגשתי תוסף שמצליח להתמודד עם כולן.
ממליץ על שילוב של ABP עם כמה שיותר פילטרים ו-Ghostery.
פילטרים הם רשימות חסימה שניתן לבחור בהגדרות התוסף.
 
3. cookie היא פיסת מידע קטנה שאתר יכול לבקש מהדפדפן שלך לשמור בשבילו על המחשב שלך.
מה יהיה בתוך ה-cookie? כל מה שהאתר ירצה.
אתרים רבים משתמשים ב-cookie כדי לשמור מפתח שהם קיבלו אחרי שהכנסת שם משתמש וססמה וככה הם מנהלים מה שנקרא seesion, כלומר יודעים מתי את מחוברת.
 
אין קשר בין דפדפן, לבין שימוש של אתר מסוים ב-cookies לצורך מעקב אחרי הרגלי הגלישה שלך.
אתר אחד אינו יכול לקרוא cookie של אתר שני, אבל יש התחכמויות אחרות בהם אתרים משתמשים.
 
למשל, Facebook יכול לדעת על כל עמוד אליו גלשת, אם בעמוד יש כפתור Like.
לצפיה ב-'תודה רבה!'
תודה רבה!
21/08/2017 | 15:19
2
23
יש לך מושג למה אתרים מסוימים לא עובדים או שפונקציות מסוימות לא עובדות אם הדפדפן שלי לא "מקבל" cookies? סתם כי הבעלים של האתר מעצבנים ועדיף לי לא להשתמש באתר הזה בכלל?
לצפיה ב-'לעזאזל!'
לעזאזל!
21/08/2017 | 15:28
1
22
עכשיו ניטרלתי את הקוקיז והג'ימייל התנתק שלי ודרש שאפעיל מחדש את הקוקיז. יש לדבר הזה סיבה הגיונית?
לצפיה ב-'כמו שכתבתי לך:'
כמו שכתבתי לך:
21/08/2017 | 15:47
24
אתרים, כולל gmail, משתמשים ב-cookies כדי לשמור token התחברות.
אחרת, היית צריכה להכניס שם משתמש וססמה כל פעם שאת עוברת עמוד באתר.
 
זה חלק מעבודה רגילה של אתרים, הם צריכים לשמור state איכשהו.
אני פרנואיד בעצמי, אבל אפילו אני לא מבטל cookies גורף, כי זה מיותר.
לצפיה ב-'איך ניתן לבצע downgrade לגירסת java'
איך ניתן לבצע downgrade לגירסת java
14/08/2017 | 13:45
7
41
שלום,
לשרת ubuntu,
התקנתי java sdk 9, אך מסתבר שכנראה תוכנות מסויימות לא יודעות לעבוד עם הגירסה הזו, ובכל התקנה אני מקבל הודעה:
   Oracle JDK 7 is NOT installed.
ההודעה נכונה גם אם אני רושם את סדרת הפקודות:
 
 
בכל מקרה, כשאני רושם את הפקודות הבאות:
   sudo dpkg -P oracle-java7-installer
sudo apt-get -f install

apt-get install default-jre
apt-get install default-jdk
(נופל בשורה האחרונה על oracle jdk 7 is not found) - בשורה של install default-jdk.
 
וכן בסדרת הפקודות:
   sudo add-apt-repository ppa:webupd8team/java
sudo apt-get update
sudo apt-get install oracle-java9-installer (latest version)
גם על השורה האחרונה נופל על  oracle jdk 7 is not found
וגם אם אשנה את השורה האחרונה ל-oracle-java7-installer, אני מקבל את אותה השגיאה.
 
כשאני רושם את הפקודה:
   java --version
אני מקבל הודעה על גירסה java 9.
 
אני צריך לעבוד עם scala עם sbt ועם התקנה של intellij IDE,
וגם עם ההתקנה של sbt, ולאחר הרצת הפקודה:
  sudo apt-get install sbt
אני שוב מקבל הודעה על:
oracle jdk 7 is not found
 
בכל מקרה, ובכל ההתקנות הקשורות - אם יש ערך ב-setup שמגדיר הגדרה כללית להפנייה ל-oracle jdk 9 (לא ברור לי למה ה-oracle ואם מדובר באותה הגירסה) - זאת במקום להפנות תמיד ל-oracle jdk 7, זה עדיף (גם אם יש הגדרה לתוכנות מסויימות שיעבדו עם oracle jdk 7 ואחרות עם oracle jdk 9, זה גם ארצה לדעת איך).
 
תודה.
לצפיה ב-'אתה שוב מתעקש לעשות בלגן.'
אתה שוב מתעקש לעשות בלגן.
15/08/2017 | 14:03
6
69
בוא ננסה לעשות קצת סדר:
 
1. Ubuntu לא מחזיקים את ה-JDK של Oracle במאגרים שלהם, למיטב זיכרוני בגלל מחלוקת משפטית.
הם מחזיקים OpenJDK במקום.
 
האם scala יכולה לעבוד עם OpenJDK?
ראה סעיף 2.
 
2. במאגרים של Ubuntu קיימת חבילה בשם scala.
אתה יכול להתקין אותה, והיא יודעת לעבוד עם ה-JDK שיש במאגרים, לא צריך Oracle Java 7
 
בנוסף, ל-sbt עצמו יש מאגר:
אם תוסיף אותו, תוכל להתקין sbt עם apt-get instll וגם הוא יעבוד בלי לדרוש Oracle Java 7.
 
3. אם אתב בכל זאת רוצה את ה-java של Oracle ובגרסה 7 על המכונה שלך, נסה את המדריך הזה:
 
הוא די ארוך, אך הסיבה לכך היא שצריך להוריד ולפרוס ידנית את הקבצים ולסדר הגדרות מערכת.
 
בהצלחה!
לצפיה ב-'כן, ייתכן שהתקנתי לא טוב ...'
כן, ייתכן שהתקנתי לא טוב ...
15/08/2017 | 22:13
5
25
בחיפוש ראשוני "install spark ubuntu latest version" התייחסתי:
 
כיוון שעיקר ההתקנה של scala באה בעקבות התקנה של spark.
 
לא הבנתי מתשובתך, סעיף 2 - איך בכל זאת להתקין מהחבילה המקורית.
>> 2. במאגרים של Ubuntu קיימת חבילה בשם scala.
איפה המאגרים? איפה החבילה? יש איזה אתר מרכז של ubuntu שאפשר להתקין? צריך שוב להתקין מחדש את החבילה של ה-scala הנכונה.
אשמח להנחיות. אני דיי חדש ב-ubuntu. בדר"כ ההתקנות זה copy+paste ממה שמוצג באתרים (ב-centos זה היה פשוט יותר נפוץ למצוא).
אם יש אתר מרכז - אשמח לדעת איך.
 
תודה.
לצפיה ב-'נפלת על מדריך לא טוב.'
נפלת על מדריך לא טוב.
16/08/2017 | 08:51
4
32
זה קורה, אבל הבעיה שלך היא שאתה לא מבין מספיק מה אתה עושה כדי לקלוט את זה.
הפנו אותך לגרסה ישנה של Java, ולא עצרת לשאול: "למה לכל הרוחות?", פשוט ניסית להחליף, אבל זה לא הלך.
 
לא נורה, ככה לומדים.
 
גיגול מהיר מביא מדריך קל ופשוט, שמוכיח שכמו שאמרתי, זה לא משנה איזו גרסת Java יש לך, ה-spark ו-scala יעבדו:
 
"להתקין מהמאגרים" אומר להשתמש במנהל החבילות, כלומר ב-apt-get.
כל מה שצריך לעשות כדי לקבל scala עובדת זה:
 sudo apt-get install scala
(אפשר גם להשתמש בממשק הגרפי שנקרא "Software center", הוא הולך לאותו מקום)
 
כדי להוסיף את המאגר של sbt, תיכנס ל-"software and updates", תעבור לטאב השני Other software, תחלץ add ותדביק פנימה את השורה שכתבתי.
 
או תעקוב אחרי המדריך אליו קישרתי בהודעה הקודמת ותדביק את הפקודות משם למסוף.
 
כאמור, מנהל החבילות של Ubuntu שנקרא apt ופונה אוטומטית למאגרים הראשיים של ההפצה, ויפנה גם לכל מאגר שתוסיף.
 
גם עבור Ubuntu יש הרבה מדריכים ברשת כי זו הפצה מאוד פופלרית, אבל זו הפצה שמתעדכנת מהר יותר מ-CentOS (שבה בשביל יציבות מעדכנים תוכנות נורא לאט, ועובדים לרוב עם גרסאות מאוד ישנות), לכן, כשאתה מוצא מדריך, אתה צריך לשים לב לתאריך שבו נכתב, או אם זה מפורט, למספר גרסה של Ubuntu שבשבילה הוא נוצר.
 
לא כל הדברים משתנים, אבל גרסאות תוכנה כן, ואם אתה רואה הפניה לגרסת תוכנה ישנה מידי, בדוק אם יש מדריך חלופי.
לצפיה ב-'או קיי, תודה.'
או קיי, תודה.
17/08/2017 | 09:47
3
22
תודה, וסליחה על הבורות.
פשוט יש לי אפשרות לכניסה לשרתים ואני צריך לעשות הכל (התקנות, תכנות ...)
 
לגבי גירסה אחורה - רציתי סוף סוף שמשהו יעבוד, ונאמר לי בפורום ש-sbt כנראה לא תומך בגירסה של java 9 (שכנראה האחרונה, וזה מה שמנהל החבילות מתקין - לא ראיתי דרך אחרת לחזור אחורה, ולכן חשבתי לתומי שאפשר להתנהל ב-2 גירסאות, אם יש תוכנות שלא תומכות ב-Java 9 ויש כאלה שכן, ולכן ה"ניסוי" שבוצע).
 
אגב, מכיר apt-get, רק לא ידעתי שהמינוח apt-get זה דרך מנהל חבילות.
 
בכל מקרה,  איפה ה-software center? זה משהו מובנה ב-ubuntu?
האם להלן זה הנתיב (אם כן - מה הנכון מבין ה-2).
 application -> system -> software
או
application -> system -> software updater
 
תודה.
לצפיה ב-'תראה, לא כתבתי שהבעיה שלך שאתה לא מבין מספיק כדי'
תראה, לא כתבתי שהבעיה שלך שאתה לא מבין מספיק כדי
18/08/2017 | 12:17
2
23
להעליב.
 
לא צריך להתנצל על הבורות, צריך פשוט להיפתר ממנה ע"י לימוד החומר הרלוונטי.
 
זה אולי לא נשמע נחמד, אבל אם אתה מחפש להיכנס למשרה של ניהול שרת, אתה צריך ללמוד איך עובדות התקנות על מערכת לינוקס לפני שאתה לומד להתקין ולעבוד עם תוכנה ספציפית.
 
זה חובה. לדעת מה היא חבילה, מאיפה היא באה, לאן היא הולכת (מה בעצם קורה כש-apt מתקין חבילה) וכו'.
 
זה חלק מאוד חשוב בניהול שרתים, כי בין היתר תלמד משם איפה חיים קבצי קונפיגורציה של תוכנות שונות שתצטרך לשנות אחרי התקנת התוכנה.
 
אין שום בעיה להחזיק 2 או יותר גרסאות Java על אותה מכונה, אבל יש כמה דברים שצריך לדעת בשביל זה.
חשבתי שאתה מחפש להרים סביבת פיתוח כמה שיותר בקלות, לכן המלצתי לך פשוט ללכת על גרסה אחת שעובדת.
 
אם אתה רוצה ללמוד איך משלבים כמה גרסאות java על מכונת Linux תתחיל מללמוד על update-alternatives.
 
Software Center מובנה ב-Ubuntu (לא שיש פה משמעות ל-"מובנה", זו סתם עוד תוכנה שמגיע עם המערכת, וזה גם עניין שמאוד כדאי לך ללמוד).
בממשק גרפי, אחרי התקנה, יופיע לך אייקון של שקית קניות בסרגל צד.
 
אני לא ממש מבין איך הגעת לנתיבים שהצגת, אלא אם אתה עובד עם גרסה ממש ישנה או ממשק שהוא לא ברירת מחדל (אם כן, ציין איזה שולחן עבודה התקנת).
 
אני יכול להגיד לך ש-Software Updater זו לא האופציה הנכונה, זו רק תוכנה קטנה שמריצה עדכונים למה שכבר מותקן לך, לא מאפשרת לך להתקין או להסיר דברים.
לצפיה ב-'לא נעלב.'
לא נעלב.
19/08/2017 | 15:18
1
34

אין לי מה להעלב.
בסך הכל אתה טורח ונותן לי תשובות מעשייות ובהתנדבות - תודה!
אני נכנס ל-ubuntu דרך vnc.
יש שרת שברשותי שאני עושה עליו מה שבא...
הוא אצל לקוח ואני נכנס דרך ה-vnc, כך שזה נראה שונה ממה שאני נכנס דרך ה-citrix.
אני בסך הכל רוצה להתקין כמה התקנות, לבדוק ולהתנסות בהתקנות. לא איזה מומחיות על. לסמן וי ולהתנסות.
מצו"ב קובץ שמראה את מסך הכניסה (זה אני רואה בכניסה מ-vnc בלבד. אפשר להסתכל על כל ה-desktop למינהם כממשק עזר גרפי, המשתמש ברכיבים קבועים של מערכת הפעלה. ב-citrix זה נראה לגמרי אחרת. אני מחפש את כל הקישורים שהצגת לפי אותו מינוח אחד-על-אחד בתפריט, אך לא מצאתי).
 
כעת מה שדחוף לי, בקשר להתקנת spark ו-scala, עדיין לא מצליח. אני מקבל הודעת שגיאה, לפי מה שפרסמתי בהודעה (אולי בשל התקנות לא תקינות, למרות ש-scala עובד דרך ה-terminal. זה כנראה הגדרות לא נכונות ב-intellij).
 
scala עובד דרך ה-terminal כשורה, באמצעות ה-intellij לא, כך שכהבנתי, זה משהו בהגדרה של Intelli (כנראה בצורת הניתוב ל-java. גם חפרתי קצת באינטרנט - לא מצאתי משהו).
 
לצפיה ב-'זה מעניין:'
זה מעניין:
19/08/2017 | 17:05
16
שולחן עבודה שרואים בתמונה נקרא XFCE.
 
בניגוד ל-Windows שם יש רק שולחן עבודה אחד והוא חלק אינטגרלי מהמערכת, ב-Linux שולחן עבודה הוא רק עוד תוכנה (בד"כ כמה תוכנות) ויש כמה כאלה.
 
כברירת מחדל, שולחן עבודה XFCE מגיע עם Xubuntu - גרסה קלה יותר של Ubuntu שמחליפה מספר תוכנות לתוכנות קלות, שלא צורכות הרבה זיכרון ומעבד.
כמובן, אם רוצים, ניתן להתקין אותה גם על Ubuntu הרגיל.
 
בנוסף, גרסאות שרת של כלל הפצות לינוקס מגיעות תמיד ללא שולחן עבודה גרפי.
 
ככל הנראה, יש משהו מאוד לא סטנדרטי במכונה שאתה עובד מולה, ואני לא יודע איך לעזור לך מכאן.
אתה יכול להמשיך לעשות התקנות עם apt דרך שורת פקודה.
 
אתה יכול להריץ:
 sudo apt-get install synaptic
 
ואז תמצא בתפריט System יישום בשם Synaptic שייתן לך ממשק גרפי להתקנות והסרות של תוכנות.
 
לגבי scala, אתה כנראה צודק בעניין הגדרות של IntelliJ, אבל אין לי מושג איך מגדירים אותו לעבוד עם scala.
ממליץ לך להעתיק את השאלה לפורום שפות תכנות או אפילו עבודה בהייטק, כי זה יותר קשור לכלי פיתוח באופן כללי, מאשר ללינוקס ספציפי (וכפי שראיתה, הפורום הזה לא הכי פעיל).
 
בהצלחה!
 
נ.ב.:
בלינוקס, זה נחשב מנהג מגונה להתקין סביבה גרפית על שרת, כי זה פותח פתח למלא בעיות:
1. עוד תוכנות, עוד מקום לבאגים
2. עוד תוכנות, עוד מקום לפרצות אבטחה
3. עוד תוכנות, עוד צריכת משאבים מיותרת
 
בנוסף, בשום סביבה לא נהוג להריץ כלי פיתוח ישירות על השרת.

חם בפורומים של תפוז

בפייסבוק שלנו כבר ביקרתם?
בפייסבוק שלנו כבר...
רוצים להיות תמיד מעודכנים במה שקורה בתפוז?
בפייסבוק שלנו כבר ביקרתם?
בפייסבוק שלנו כבר...
רוצים להיות תמיד מעודכנים במה שקורה בתפוז?

מקרא סימנים

בעלת תוכן
ללא תוכן
הודעה חדשה
הודעה נעוצה
אורח בפורום
הודעה ערוכה
מכיל תמונה
מכיל וידאו
מכיל קובץ